Back to overview
Degraded

Economic Calendar and Forex News are down

Feb 18, 2026 at 02:53am UTC
Affected services
Economic Calendar
Forex News

Resolved
Feb 18, 2026 at 06:37am UTC

Economic Calendar and Forex News recovered.

Updated
Feb 18, 2026 at 02:56am UTC

Economic Calendar is degraded.

Created
Feb 18, 2026 at 02:53am UTC

Forex News is degraded.