Back to overview
Slow response times
Oct 15, 2025 at 12:32pm UTC
Affected services
Zennbot App
Resolved
Oct 15, 2025 at 12:32pm UTC
We are investigating unusually slow response times in the app.
Affected services
Resolved
Oct 15, 2025 at 12:32pm UTC
We are investigating unusually slow response times in the app.
Affected services