Back to overview
Degraded

Economic Calendar and Forex News are down

Aug 30 at 04:30pm CEST
Affected services
Economic Calendar
Forex News

Resolved
Aug 31 at 10:16am CEST

Economic Calendar and Forex News recovered.

Updated
Aug 30 at 04:51pm CEST

Forex News is degraded.

Created
Aug 30 at 04:30pm CEST

Economic Calendar is degraded.